ENVI Tutorial: Advanced Hyperspectral Analysis

Table of Contents

OVERVIEW OF THIS TUTORIAL.....................................................................................................................................3
MNF TRANSFORMS AND ENDMEMBERS.............................................................................................................4
  Background: MNF Transforms ..........................................................................................................................4
  Open EFFORT-Corrected Data .........................................................................................................................4
  Open and Load MNF Image............................................................................................................................5
  Compare MNF Images .....................................................................................................................................5
  Examine MNF Scatter Plots ...............................................................................................................................5
  Use Scatter Plots to Select Endmembers .......................................................................................................6
PIXEL PURITY INDEX........................................................................................................................................8
  Display and Analyze the Pixel Purity Index.....................................................................................................8
  Threshold PPI to Regions of Interest.................................................................................................................9
THE n-D VISUALIZER .....................................................................................................................................11
  Compare n-D Data Visualization with a 2D Scatter Plot ...............................................................................11
  Use the n-D Visualizer ..................................................................................................................................13
  Select Endmembers .......................................................................................................................................13
  Use the n-D Class Controls ..........................................................................................................................14
  Link the n-D Visualizer to Spectral Profiles .................................................................................................14
  Link the Spectral Analyst to the n-D Visualizer Spectra ...............................................................................14
Load Individual Spectra Into the n-D Visualizer.................................................................................. 15
Collapse Classes in the n-D Visualizer........................................................................................................ 16
Export Your Own ROIs......................................................................................................................... 16
Save Your n-D Visualizer State ........................................................................................................ 16
Restore n-D Visualizer Saved State .................................................................................................. 16
Close all Display Groups and Windows .............................................................................................. 17
SPECTRAL MAPPING............................................................................................................................... 18
What Causes Spectral Mixing........................................................................................................ 18
Modeling Mixed Spectra................................................................................................................ 19
Practical Unmixing Methods........................................................................................................... 20
LINEAR SPECTRAL UNMIXING RESULTS................................................................................................. 21
Open and Display Linear Spectral Unmixing Results........................................................................ 21
Determine Abundance .................................................................................................................. 21
Display a Color Composite........................................................................................................... 21
MIXTURE-TUNED MATCHED FILTERING ........................................................................................................................ 22
Perform Your Own MTMF............................................................................................................... 22
Display and compare the EFFORT and MNF Data........................................................................... 22
Collect EFFORT and MNF Endmember Spectra........................................................................... 22
Calculate MTMF Images................................................................................................................ 23
Display MTMF Results................................................................................................................ 23
Display Scatter Plots of MF Score versus Infeasibility..................................................................... 24
REFERENCES............................................................................................................................... 25
Overview of This Tutorial

This tutorial is designed to introduce you to advanced concepts and procedures for analyzing imaging spectrometer data or hyperspectral images. You will use Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) EFFORT-polished, atmospherically corrected apparent reflectance data from Cuprite, Nevada, USA, to investigate sub-pixel properties of hyperspectral data and advanced techniques for identifying and quantifying mineralogy. You will also review Matched Filtering and Linear Spectral Unmixing results. This tutorial is designed to be completed in two to four hours.

Files Used in This Tutorial
CD-ROM: Tutorial Data CD #2
Path: envidata\c95avsub

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cup95eff.int (.hdr)</td>
<td>AVIRIS EFFORT-polished, atmospherically corrected apparent reflectance data</td>
</tr>
<tr>
<td>cup95mnf.dat (.hdr)</td>
<td>First 25 Minimum Noise Fraction (MNF) bands</td>
</tr>
<tr>
<td>cup95mnf.asc</td>
<td>MNF eigenvalue spectrum</td>
</tr>
<tr>
<td>cup95mnf.sta</td>
<td>MNF statistics</td>
</tr>
<tr>
<td>cup95ppi.dat (.hdr)</td>
<td>Pixel Purity Index (PPI) image</td>
</tr>
<tr>
<td>cup95ppi.roi</td>
<td>Region of interest (ROI) for PPI values greater than 1750</td>
</tr>
<tr>
<td>cup95ppi.ndv</td>
<td>n-D Visualizer saved state file</td>
</tr>
<tr>
<td>cup95ndv.roi</td>
<td>ROI endmembers corresponding to the n-D Visualizer saved state file</td>
</tr>
<tr>
<td>cup95_em.asc</td>
<td>EFFORT ASCII file of 11 spectral endmembers selected using the PPI threshold, MNF images, and n-D Visualization</td>
</tr>
<tr>
<td>cup95_mnfem.asc</td>
<td>MNF ASCII file of 11 spectral endmembers selected using the PPI threshold, MNF images, and n-D Visualization</td>
</tr>
<tr>
<td>cup95unm.dat</td>
<td>Unmixing results—fractional abundance images</td>
</tr>
<tr>
<td>usgs_min.sli (.hdr)</td>
<td>USGS spectral library in ENVI format</td>
</tr>
</tbody>
</table>
MNF Transforms and Endmembers

Background: MNF Transforms

The Minimum Noise Fraction (MNF) transform is used to determine the inherent dimensionality of image data, to segregate noise in the data, and to reduce the computational requirements for subsequent processing (Boardman and Kruse, 1994). The MNF transform as modified from Green et al. (1988) and implemented in ENVI, is essentially two cascaded Principal Components transformations. The first transformation, based on an estimated noise covariance matrix, decorrelates and rescales the noise in the data. This first step results in transformed data in which the noise has unit variance and no band-to-band correlations. The second step is a standard Principal Components transformation of the noise-whitened data. For the purposes of further spectral processing, the inherent dimensionality of the data is determined by examination of the final eigenvalues and the associated images. The data space can be divided into two parts: one part associated with large eigenvalues and coherent eigenimages, and a complementary part with near-unity eigenvalues and noise-dominated images. By using only the coherent portions, the noise is separated from the data, thus improving spectral processing results.

The figure below summarizes the MNF procedure in ENVI. The noise estimate can come from one of three sources; from the dark current image acquired with the data (for example, AVIRIS), from noise statistics calculated from the data, or from statistics saved from a previous transform. Both the eigenvalues and the MNF images (eigenimages) are used to evaluate the dimensionality of the data. Eigenvalues for bands that contain information will be an order of magnitude larger than those that contain only noise. The corresponding images will be spatially coherent, while the noise images will not contain any spatial information.

Open EFFORT-Corrected Data

Empirical Flat Field Optimized Reflectance Transformation (EFFORT) is a correction method used to remove residual “saw-tooth” instrument (or calibration-introduced) noise and atmospheric effects from AVIRIS data. It is a custom correction designed to improve the overall quality of spectra, and it provides the best reflectance spectra available from AVIRIS data.

1. From the ENVI main menu bar, select **File → Open Image File.** A file selection dialog appears.

2. **Navigate to** envidata\c95avsub and select **cup95eff.int.** Click **Open.**

3. In the Available Bands List, select **Band 193** under cup95eff.int. Select the **Gray Scale** radio button, and click **Load Band.**
Open and Load MNF Image
1. From the ENVI main menu bar, select **File → Open Image File**. A file selection dialog appears.

2. Navigate to `envidata\c95avsub` and select `cup95mnf.dat`. Click **Open**. This dataset contains the first 25 MNF bands (floating-point) from the Cuprite EFFORT-corrected data.

3. In the Available Bands List, select **MNF Band 1** under `cup95mnf.dat`. Select the **Gray Scale** radio button.

4. In the Available Bands List, click **Display #1** and select **New Display**. Click **Load Band**.

Compare MNF Images
1. From a Display group menu bar, select **Tools → Link → Link Displays**. Click **OK** to link the two display groups.

2. Click in an Image window to use dynamic overlay to compare the two images.

3. From a Display group menu bar, select **Tools → Link → Dynamic Overlay Off**.

4. From both Display group menu bars, select **Tools → Profiles → Z Profile (Spectrum)**. Compare the MNF spectra with the apparent reflectance spectra from the EFFORT-corrected data.

5. Do you see a pattern or relationship between the MNF image and the apparent reflectance image? Relate the MNF band number to MNF image quality.

Examine MNF Scatter Plots
1. From the Display #2 menu bar, select **Tools → 2D Scatter Plots**. A Scatter Plot Band Choice dialog appears.

2. Choose two bands to scatter plot and click **OK**. Try different band combinations. Once you plot the data, you can change the bands to plot by selecting **Options → Change Bands** from the Scatter Plot window menu bar. Be sure to choose a high-variance (low band number) MNF band. Also, examine at least one scatter plot of a low-variance (high band number) MNF band. Notice the corners (pointed edges) on some MNF scatter plots, as the following figure shows.
3. Use linked display groups, dynamic overlays, and Z Profiles to understand the reflectance spectra of the MNF corner pixels. Look for areas where the MNF data transition from “pointy” to “fuzzy.” Also notice the relationship between scatter plot pixel location and spectral mixing as determined from image color and individual reflectance spectra. How do you explain these patterns? How can you exploit them?

Use Scatter Plots to Select Endmembers
You will now investigate the possibilities of deriving unmixing endmembers from the data using MNF images and 2D scatter plots.

1. From the Scatter Plot menu bar, select **Options → Change Bands**. A Scatter Plot Band Choice dialog appears.
2. Under **Choose Band X**, select **MNF Band 1**. Under **Choose Band Y**, select **MNF Band 2**. Click **OK**.
3. In the Scatter Plot, draw a polygon ROI around a few extreme data points in a corner or arm of the data cloud. The following figure shows an example:

![Scatter Plot Example](image)

Right-click to close the polygon. These data points are mapped in the corresponding image as colored pixels.

4. From the Scatter Plot menu bar, select **Class** and choose a different color. This starts a new class. Draw another polygon ROI around a few extreme data points in a different corner or arm of the data cloud.
5. Click-and-drag inside the MNF Image window to view the corresponding pixels in the Scatter Plot, shown as "dancing pixels." Or, click-and-drag the middle mouse button inside the Scatter Plot to highlight the corresponding pixels in the Image window.
6. From the Scatter Plot menu bar, select **Options → Export All**. An ROI Tool dialog appears with a list of the ROIs you defined.
7. Repeat Steps 1-6, using different combinations of the first several MNF bands. It is important to use different band combinations to identify the most spectrally unique materials. Corner pixels generally make good...
endmember estimates, however you will see several overlapping or repeating ROIs. This is a limitation of examining the data in a pairwise (2D) fashion.

8. Load your ROIs into the apparent reflectance image by selecting **Overlay → Region of Interest** from the Display #1 menu bar.

9. In the ROI Tool dialog, click **Select All**, followed by **Stats**, to extract the mean apparent reflectance spectra of the ROIs. An ROI Statistics Results dialog appears.

10. From the ROI Statistics Results menu bar, select **Plot → Mean for all ROIs** to extract the mean apparent reflectance spectra of the ROIs.

11. Use the linked display groups and Z Profiles to examine the relationship between the MNF and reflectance spectra.

12. From the Scatter Plot menu bar, select **File → Cancel**. Close the ROI Statistics Results dialog. Keep the display groups open for the next exercise.
Pixel Purity Index

Separating purer pixels from more mixed pixels reduces the number of pixels to analyze for determining endmembers, and it makes separation and identification of endmembers easier.

The Pixel Purity Index (PPI) is a means of finding the most “spectrally pure,” or extreme, pixels in multispectral and hyperspectral images (Boardman et al., 1995). The most spectrally pure pixels typically correspond to mixing endmembers. You compute the PPI by repeatedly projecting n-dimensional (n-D) scatter plots onto a random unit vector. ENVI records the extreme pixels in each projection—those pixels that fall onto the ends of the unit vector—and it notes the total number of times each pixel is marked as extreme. A PPI image is created where each pixel value corresponds to the number of times that pixel was recorded as extreme. The following diagram summarizes the use of PPI in ENVI:

Display and Analyze the Pixel Purity Index

In this exercise, you will examine the role of convex geometry in determining the relative purity of pixels.

1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears.

2. Navigate to envidata\c95avsub and select cup95ppi.dat. Click Open.

3. In the Available Bands List, click Display #2 and select New Display.

4. Select the Gray Scale radio button. Select PPI Result and click Load Band.

Following is a summary of what each display group should contain at this point. Displays #1 and #2 should still be open from the previous exercise.

Display #1: EFFORT-corrected apparent reflectance data (cup95eff.int)
Display #2: MNF data (cup95mnf.dat)
Display #3: PPI results (cup95ppi.dat)

Brighter pixels in the PPI image represent more spectrally extreme finds (hits) and indicate pixels that are more spectrally pure. Darker pixels are less spectrally pure.
5. From the Display #3 menu bar, select **Enhance** and try various interactive stretches to understand the PPI image's histogram and data distribution. Why is the histogram skewed to the low values? What does this mean from a mixing point of view?

The PPI image is the result of several thousand iterations of the PPI algorithm on the MNF data. The values in the PPI image indicate the number of times each pixel was discovered as extreme in some projection. These numbers then indicate the degree of local convexity of the data cloud near each pixel and the proximity of each pixel to the convex hull of the data. In short, the higher values indicate pixels that are nearer to corners of the n-D data cloud, and are thus relatively purer than pixels with lower values. Pixels with values of 0 were never found to be extreme.

6. From a Display group menu bar, select **Tools → Link → Link Displays** and click **OK** to link all three display groups.

7. From each Display group menu bar, select **Tools → Profiles → Z Profile (Spectrum)**. Now you can examine the spectral profiles of selected pixels in the PPI display group.

8. From the Display #3 menu bar, select **Tools → Cursor Location/Value** and examine the range of data values in the PPI image.

9. Move around the PPI image, and use the Spectral Profile window and dynamic overlay to examine the purest pixels, both spatially and spectrally.

Do any of the high PPI values fall in the regions of the image corresponding to the 2D plot corners you selected in the previous exercise? Why?

### Threshold PPI to Regions of Interest

1. From the Display #3 menu bar, select **Tools → Region of Interest → ROI Tool**. The ROI Tool dialog appears.

2. From the ROI Tool menu bar, select **File → Restore ROIs**. A file selection dialog appears.

3. Select `cup95ppi.roi` and click **Open**. An ENVI Message dialog appears with information about the ROI. Click **OK**. This ROI represents a collection of pixels where the PPI value is over 1750.

   How many high PPI pixels are there?

   Next, you will create your own thresholded PPI ROIs.

4. From the Display #3 menu bar, select **Enhance → Interactive Stretching**.

5. To determine a threshold to use for choosing only the purest pixels, read and understand the data values from the histogram. Click the middle mouse button in the histogram to zoom to the lower end of the distribution. Click-and-hold the left mouse button as you browse the histogram.

6. Select a value on the high tail of the histogram as the minimum threshold (if this seems too difficult, try a value of 2000 as a starting point).

7. From the ROI Tool menu bar, select **Options → Band Threshold to ROI** to create an ROI containing only the pixels with high PPI values. A file selection dialog appears.

8. Select **PPI Result** under `cup95ppi.dat` and click **Open**. A Band Threshold to ROI Parameters dialog appears.

9. In the **Min Thresh Value** field, enter the value you determined in Step 6. Click **OK**. ENVI determines the number of pixels that meet the selected criteria and issues an ENVI Question dialog. For this exercise, if your threshold results in more than 2000 pixels being selected, you should select a higher minimum threshold.
10. Click **Yes** in the ENVI Question dialog. A new ROI called "Thresh..." appears near the bottom of the table in the ROI Tool dialog. This ROI contains the pixel locations of the purest pixels in the image, regardless of the endmember to which they correspond.

In the next exercise, you will use the n-D Visualizer to isolate the specific pure endmembers.
The n-D Visualizer

The n-D Visualizer is an interactive tool to use for selecting the endmembers in n-D space. You can think of spectra as points in an n-D scatter plot, where \( n \) is the number of bands. The coordinates of the points in n-D space consist of \( n \) spectral radiance or reflectance values in each band for a given pixel. You can use the distribution of these points in n-D space to estimate the number of spectral endmembers and their pure spectral signatures.

When using the n-D Visualizer, you can interactively rotate data in n-D space, select groups of pixels into classes, and collapse classes to make additional class selections easier. You can export the selected classes to ROIs and use them as input into classification, Linear Spectral Unmixing, or Matched Filtering techniques. The following figure summarizes the steps involved in using the n-D Visualizer to select endmember spectra.

Compare n-D Data Visualization with a 2D Scatter Plot

1. From the ENVI main menu bar, select Spectral → n-Dimensional Visualizer → Visualize with New Data. A file selection dialog appears.

   To visualize pixels in the n-D Visualizer scatter plot, you must define an ROI from a PPI image. You performed this step in the previous exercise.


3. Select MNF Band 1, hold down the \(<\text{Shift}>\) key, and select MNF Band 10. Click OK. The first several bands of the MNF file encompass most of the variance in the original data set. Limiting the number of bands improves the performance of the n-D Visualizer.

4. Click OK in the n-D Visualizer Input File dialog. An n-D Visualizer Input ROI dialog appears.
If only one valid ROI was listed in the ROI Tools dialog, those ROI data would be automatically loaded into the n-D Visualizer. If more than one ROI is listed, choose the ROI derived using the PPI threshold when queried.

5. In the n-D Visualizer Input ROI dialog, select **Thresh**... and click **OK**. An n-D Visualizer plot window and n-D Controls dialog appear. Each number in the n-D Controls dialog represents a spectral band.

6. Click 1 and 2 to create a 2D scatter plot of the purest pixels from bands 1 and 2.

7. From the Display #3 menu bar, select **Tools → 2D Scatter Plots**. A Scatter Plot Band Choice dialog appears.

8. Under **Choose Band X**, select **MNF Band 1**. Under **Choose Band Y**, select **MNF Band 2**. Click **OK**. A Scatter Plot window appears.

9. Compare the two scatter plots. Can you see how pixels were excluded from the n-D Visualizer, based on pixel purity? Why is this important?

10. Close the Scatter Plot window.
Use the n-D Visualizer

1. Use the n-D Controls dialog to select different band combinations. Note the shape of the data clouds in the n-D Visualizer. Examine some of the higher-order MNF bands.

2. In the n-D Controls dialog, select three bands to view. Now you can change the view of the projection by selecting **Options → 3D: Drive Axes** from the n-D Controls dialog menu bar.

3. Click-and-drag the left mouse button in the n-D Visualizer to rotate the projection. Note the shape of the data clouds.

4. Turn on the axes by selecting **Options → Show Axes** from the n-D Controls dialog menu bar.

5. Click **Start**. You should see an animation of random projections of n-D space into the scatter plot. In this mode, you can examine several bands simultaneously.

6. In the n-D Controls dialog, select bands 1 through 5 to view a projection of 5-D data. Click on the bands again to deselect them.

7. Try a few different combinations of at least two different bands to obtain different views of the n-D data. Try MNF band 9 versus MNF band 10 to see how they compare to 1 versus 2.

8. Click **Stop** and use the arrow buttons next to the **Step** text label to step forward and backward through the projections. The New button loads a new random projection. Enter lower or higher **Speed** values to slow down or speed up the rotation.

   The rotations seem different when you include more than three bands. With more than three dimensions, the data points “fold” in upon themselves in the projection. This should convince you that the data are truly high-dimensional and why 2D scatter plots are inadequate for analyzing hyperspectral data.

Select Endmembers

1. Click **Start** again in the n-D Controls dialog to view an animation.

2. When you see an interesting projection (one with obvious points or corners), click **Stop**.

3. Select **Class** from the n-D Controls dialog menu bar, and select a color.

4. In the n-D Visualizer, draw a polygon ROI around a corner of the data cloud. Right-click to close the polygon. This is how you **paint**, or select, endmembers. The following figure shows an example:
5. Click **Start** again and watch the same corner where you defined your ROI. You may see new endmembers in this region as the data cloud rotates in different projections. Draw more polygon ROIs around the corner as necessary to include more endmembers. You are currently only defining one class.

6. If you no longer want to include certain endmembers that you previously identified, you can "erase" them by selecting **Class → Items 1:20 → White** from the n-D Controls dialog menu bar. Then, draw a polygon around those endmembers.

7. From the n-D Controls dialog menu bar, select **Class → New**. Repeat Steps 4-5 to define polygon ROIs around another data corner. Create a few more classes based on this process.

Use the n-D Class Controls

1. Select **Options → Class Controls** from the n-D Controls dialog menu bar.
   
   The n-D Class Controls dialog appears. This dialog lists the number of points in each defined class and the class color. You can change the symbol, turn individual classes on and off, and select classes to collapse. You can also plot the minimum, maximum, mean, and standard deviation spectra for a class, plot the mean for a single class, and plot all the spectra within a class. Also, you can clear a class and export a class to an ROI.

2. Experiment with the different functions available in the n-D Class Controls dialog, and close the dialog when you are finished.

Link the n-D Visualizer to Spectral Profiles

You can view reflectance spectra for specific endmembers while you are selecting endmembers and rotating the scatter plot. This allows you to preview spectra before finalizing spectral classes.

1. From the n-D Controls dialog menu bar, select **Options → Z Profile**. A file selection dialog appears.

2. Select **cup95eff.int** and click **OK**. A blank n-D Profile plot window appears.

3. Click the middle mouse button in the n-D Visualizer. A spectrum for the current pixel appears in the n-D Profile.

4. Click the middle mouse button inside the n-D Visualizer to interactively view the corresponding spectrum. When you middle-click inside a group of endmembers belonging to a certain class, the spectral profile shows the corresponding class color.

5. Right-click once inside the n-D Profile. Then, right-click in the n-D Visualizer to collect spectra in the n-D Profile. Each subsequent spectrum is retained in the n-D Profile, without erasing the previous spectrum. Click the middle mouse button in the n-D Visualizer to clear the plot and to return to single-spectrum mode.

Link the Spectral Analyst to the n-D Visualizer Spectra

ENVI’s Spectral Analyst uses several methods to match unknown spectra to library spectra. It provides a score (from 0 to 1) with respect to the library spectra. A value of 1 means a perfect match. Linking the Spectral Analyst to the n-D Visualizer allows you to identify endmember spectra on-the-fly.

1. From the ENVI main menu bar, select **Spectral → Spectral Analyst**.

2. In the Spectral Analyst Input Spectral Library dialog, click **Open** and select **Spectral Library**. A file selection dialog appears.

3. Navigate to **envidata\spec_lib\usgs_min** and select **usgs_min.sli**. Click **Open**.

5. Click OK in the Edit Identify Methods Weighting dialog.


7. Select n-D Profile: cup95eff.int and click OK.

8. Click the middle mouse button inside one of your defined classes in the n-D visualizer. The Spectral Analyst scores the unknown spectrum against the USGS spectral library. High scores indicates a high likelihood of match.

9. In the Spectral Analyst dialog, double-click on the spectrum name at the top of the list to plot the unknown and the library spectrum in the same plot for comparison. Use the Spectral Analyst and the comparison plots to determine the possible mineralogy for the n-D Visualizer spectra you have extracted. When you have identified several minerals, continue with the next section.

10. Close the Spectral Analyst when you are finished.

Load Individual Spectra Into the n-D Visualizer

1. In the ROI Tool dialog, select the Off radio button.

2. From the Display #1 menu bar (containing the EFFORT-corrected apparent reflectance data), select Tools → Profiles → Z Profile.

   (Since so many dialogs are currently open, you may want to select Window → Window Finder from the ENVI main menu bar to help locate Display #1.)

3. Ensure that dynamic overlay is turned off in this image. From the Display #1 menu bar, select Tools → Link → Dynamic Overlay Off.

4. From the Display #1 menu bar, select Tools → Profiles → Additional Z Profile. A file selection dialog appears.

5. Select cup95mnf.dat and click OK.

6. Because the data in the n-D Visualizer are in MNF space, you must import the MNF spectra that represent the materials of interest.

7. From the n-D Controls dialog, select Options → Import Library Spectra. The n-D Visualizer Import Spectra dialog appears (a standard ENVI Endmember Collection dialog).

8. Move the cursor in the #1 Zoom window until the crosshairs are over a pixel you are interested in. The reflectance spectrum is displayed in the #1 Spectral Profile window. The additional spectral profile is linked and shows the corresponding MNF spectrum.

9. Right-click in the additional spectral profile and select Plot Key to show the spectrum name. Click and drag the spectrum name from the additional spectral profile into the table of the Endmember Collection dialog. The spectrum is plotted in the n-D Visualizer window with a flag marking its position.

10. Repeat for as many spectra as desired. You can rotate the spectra along with the PPI-derived data in the n-D Visualizer.
Collapse Classes in the n-D Visualizer

Once you have identified a few endmembers, you may find it difficult to locate additional endmembers, even after rotating the data clouds and viewing different 2D projections of the n-D data.

To help solve this problem, you can collapse classes in ENVI by grouping the endmembers you have already found into one group representing the background. Mixing features that were previously hidden become visible, and you can select them by drawing ROIs in the n-D Visualizer.

Select Options → Collapse Classes by Means from the n-D Controls dialog menu bar to geometrically project the selected data according to their class mean values. Or, select Options → Collapse Classes by Variance. Use the Z Profile tool to verify that you are choosing homogeneous endmember classes.

The selected bands are listed in red, and only two are chosen. Additionally, a MNF plot appears, estimating the dimensionality of the data and the number of remaining endmembers to be found. Repeat endmember selection and class collapsing until there are no new endmembers.

Export Your Own ROIs

You can export mean spectra for the selected endmembers.

1. Delete all of the previous ROIs by clicking Select All then Delete in the ROI Tool dialog.
2. Export your best set of classes to ROIs by selecting Options → Export All in the n-D Control dialog. You can also export individual classes from the n-D Class Controls dialog by selecting Options → Class Controls. Examine the ROI spatial locations.
3. Extract the average spectra for the different ROIs by clicking Stats or Mean in the n-D Control dialog. Compare these endmembers to those extracted using the 2D scatter plots and those used in the previous exercises.
4. Select Options → Z-Profile in the n-D Controls dialog to compare single spectra with average spectra.

Save Your n-D Visualizer State

1. From the n-D Controls dialog menu bar, select File → Save State. Enter the output filename cup95.ndv and click OK. You can later restore this saved state.
2. From the n-D Controls dialog menu bar, select File → Cancel to close this n-D Visualizer.

Restore n-D Visualizer Saved State

1. Start another n-D Visualizer session using previously saved parameters and painted endmembers by selecting Spectral → n-Dimensional Visualizer → Visualize with Previously Saved Data from the ENVI main menu bar. A file selection dialog appears.
2. Select cup95ppi.ndv and click Open. New n-D Visualizer and n-D Controls dialogs appear.
3. Click Start to rotate the data. The colored pixels in the visualizer represent previously selected endmembers.
4. Examine different projections and numbers of bands in the visualizer.
5. Click Stop.
6. In the ROI Tool dialog, click Select All then Delete to remove all previous ROIs.
7. From the n-D Controls dialog, select Options → Export All.
8. In the ROI Tool dialog, click **Select All** and **Stats**. An ROI Statistics Results dialog appears. Make sure the embedded plot title says "ROI Means: cup95eff.int."

9. In the ROI Statistics Results dialog, click **Select Plot** and select **Mean for all ROIs** to extract average reflectance spectra for all of the endmembers.

10. Right-click in the plot window (in the ROI Statistics Results dialog) and select **Plot Key**. Right-click again and select **Stack Plots**.

11. Right-click in the plot window and select **Edit → Plot Parameters**. Enter a **Right Margin** value that allows you to see more of the plot legend. Your plot should look similar to the following:

   ![ROI Means: cup95eff.int](image)

12. Examine the relationship between reflectance spectra and the painted pixels in the n-D Visualizer. Pay particular attention to similar spectra and the positions of painted clusters.

13. When you are finished, close the ROI Statistics Results dialog.

**Close all Display Groups and Windows**

1. From the Available Bands List, select **File → Close All Files** to close all open files and associated display groups.

2. From the n-D Controls dialog menu bar, select **File → Cancel**.
Spectral Mapping

ENVI provides a variety of spectral mapping methods whose success depends on the data type and quality, and the desired results. These include the Spectral Angle Mapper (SAM) classification, Linear Spectral Unmixing, Matched Filtering, and Mixture-Tuned Matched Filtering (MTMF).

SAM is an automated method for comparing image spectra to individual spectra. It determines the similarity between two spectra by calculating the spectral angle between them, treating them as vectors in a space with dimensionality equal to the number of bands. This provides a good attempt at mapping the predominant spectrally active material present in a pixel. However, natural surfaces are rarely composed of a single uniform material.

Spectral mixing occurs when materials with different spectral properties are represented by a single image pixel. Several researchers have investigated mixing scales and linearity. Singer and McCord (1979) found that if the scale of the mixing is large (macroscopic), mixing occurs in a linear fashion, as the following figure illustrates. For microscopic or intimate mixtures, the mixing is generally nonlinear (Nash and Conel, 1974; Singer, 1981).

The linear model assumes no interaction between materials. If each photon only sees one material, these signals add (a linear process). Multiple scattering involving several materials can be thought of as cascaded multiplications (a non-linear process). The spatial scale of the mixing and the physical distribution of the materials govern the degree of non-linearity. Large-scale aerial mixing is very linear. Small-scale intimate mixtures are slightly non-linear. In most cases, the non-linear mixing is a second-order effect. Many surface materials mix in non-linear fashions, but approximations of linear unmixing techniques appear to work well in many circumstances (Boardman and Kruse, 1994). Using linear methods to estimate material abundance is not as accurate as using non-linear techniques, but to the first order, they adequately represent conditions at the surface.

What Causes Spectral Mixing

A variety of factors interact to produce the signal received by the imaging spectrometer:

A very thin volume of material interacts with incident sunlight. All the materials present in this volume contribute to the total reflected signal.

Spatial mixing of materials in the area represented by a single pixel results in spectrally mixed reflected signals.
Variable illumination due to topography (shade) and actual shadow in the area represented by the pixel further modify the reflected signal, basically mixing with a black endmember.

The imaging spectrometer integrates the reflected light from each pixel.

**Modeling Mixed Spectra**

The simplest model of a mixed spectrum is a linear model, in which the spectrum is a linear combination of the pure spectra of the materials located in the pixel area, weighted by their fractional abundance:

![Linear mixing for a single pixel](image)

This simple model can be formalized as a physical model, a mathematical model, and a geometric model.

The physical model includes the ground instantaneous field of view (GIFOV) of the pixels, the incoming irradiance, the photon-material interactions, and the resulting mixed spectra. A more abstract mathematical model is required to simplify the problem and to allow inversion, or unmixing.

A spectral library forms the initial data matrix for the analysis. The ideal spectral library contains endmembers that when linearly combined can form all other spectra. The mathematical model is very simple. The observed spectrum (a vector) is considered to be the product of multiplying the mixing library of pure endmember spectra (a matrix) by the endmember abundance (a vector). An inverse of the original spectral library matrix is formed by multiplying the transposes of the orthogonal matrices and the reciprocal values of the diagonal matrix (Boardman, 1989). A simple vector-matrix multiplication between the inverse library matrix and an observed mixed spectrum gives an estimate of the abundance of the library endmembers for the unknown spectrum.

The geometric mixing model provides an alternate, intuitive means to understand spectral mixing. Mixed pixels are visualized as points in n-D scatter plot (spectral) space, where n is the number of bands. If only two endmembers mix in 2D space, then the mixed pixels fall in a line. The pure endmembers fall at the two ends of the mixing line. If three endmembers mix, then the mixed pixels fall inside a triangle. Mixtures of endmembers fill in between the endmembers.

All mixed spectra are interior to the pure endmembers, inside the simplex formed by the endmember vertices, because all the abundance are positive and sum to unity. This convex set of mixed pixels can be used to determine how many endmembers are present and to estimate their spectra. The geometric model is extensible to higher dimensions where the number of mixing endmembers is one more than the inherent dimensionality of the mixed data.
Practical Unmixing Methods

Two very different types of unmixing are typically used: known endmembers and derived endmembers.

Known endmembers are used to derive the apparent fractional abundance of each endmember material in each pixel, given a set of known or assumed spectral endmembers. These known endmembers can be drawn from the data (averages of regions picked using previous knowledge), drawn from a library of pure materials by interactively browsing through the imaging spectrometer data to determine what pure materials exist in the image, or determined using expert systems as described above or other routines to identify materials.

The mixing endmember matrix is made up of spectra from the image or a reference library. The problem can be cast in terms of an over-determined, linear, least-squares problem. The mixing matrix is inverted and multiplied by the observed spectra to obtain least-squares estimates of the unknown endmember abundance fractions. Constraints can be placed on the solutions to give positive fractions that sum to unity. Shade and shadow are included either implicitly (fractions sum to 1 or less) or explicitly as an endmember (fractions sum to 1).

The second unmixing method uses the imaging spectrometer data to *derive* the mixing endmembers (Boardman and Kruse, 1994). The inherent dimensionality of the data is determined using a special orthogonalization procedure related to principal components:

- Derive a linear sub-space (flat) that spans the entire signal in the data
- Project the data onto this subspace, lowering the dimensionality of the unmixing and removing most of the noise
- Find the convex hull of these projected data
- Shrink-wrap the data by a simplex of n-dimensions, giving estimates of the pure endmembers.
- These derived endmembers must give feasible abundance estimates (positive fractions that sum to unity).

Spectral unmixing is one of the most promising hyperspectral analysis research areas. Analysis procedures using the convex geometry approach already developed for AVIRIS data have produced quantitative mapping results for a variety of materials (geology, vegetation, oceanography) without a priori knowledge. Combining the unmixing approach with model-based data calibration and expert system identification could potentially result in an end-to-end quantitative, yet automated, analysis methodology.
Linear Spectral Unmixing Results

In this section, you will examine the results of Linear Spectral Unmixing using the means of the ROIs restored above and applied to the first ten MNF bands.

Open and Display Linear Spectral Unmixing Results

1. From the ENVI main menu bar, select **File → Open Image File**. A file selection dialog appears.

2. **Navigate to** `envidata\c95avsub` and select `cup95unm.dat`. Click **Open**.

3. In the Available Bands List, scroll to the right to see the full band names. Select the **Kaolinite** band, select the **Gray Scale** radio button, and click **Load Band**. Brighter areas correspond to higher abundances.

4. From the Display group menu bar, select **Tools → Cursor Location/Value**. Examine the abundance data values in this image.

5. Use contrast stretching, if necessary, to show only the higher values (larger apparent abundances).

6. Load other fractional abundance images into one or more displays and compare the distribution of endmembers.

Determine Abundance

1. From the Available Bands List, start a new display group.

2. From the ENVI main menu bar, select **File → Open Image File**. A file selection dialog appears.

3. **Navigate to** `envidata\c95avsub` and select `cup95eff.int`. Click **Open**. A color composite is automatically loaded into the new display group.

4. From the Display group menu bar associated with `cup95eff.int`, select **Tools → Profiles → Z Profile (Spectrum)**. Examine the spectral profiles of the reflectance data to reconcile absorption band strength with apparent abundance of the various endmembers.

Display a Color Composite

1. Choose three good unmixing result images and create an RGB color composite from them.

2. Use spatial and spectral clues to evaluate the results of the unmixing.

3. Explain the colors of fractional endmembers in terms of mixing. Notice the occurrence of non-primary colors (not R, G, or B). Are all of the fractions feasible? Note areas where unreasonable results were obtained (e.g., fractions greater than one or less than zero).

4. Examine the **RMS Error** image and look for areas with high errors (bright areas in the image). Are there other endmembers that could be used for iterative unmixing? How do you reconcile these results if the RMS Error image does not have any high errors, yet there are negative abundances or abundances greater than 1.0?

5. From the Available Bands List, select **File → Close All Files**.
Mixture-Tuned Matched Filtering

Matched Filtering removes the requirement of knowing all of the endmembers by maximizing the response of a known endmember and suppressing the response of the composite unknown background, thus matching the known signature (Chen and Reed, 1987; Stoker et al., 1990; Yu et al., 1993; Harsanyi and Chang, 1994). It provides a rapid means of detecting specific minerals based on matches to specific library or image endmember spectra. This technique produces images similar to the unmixing, but with significantly less computation and without the requirement to know all the endmembers. It does, however, suffer from high false alarm rates, where materials may be randomly matched if they are rare in a pixel (thus not contributing to the background covariance).

Mixture-Tuned Matched Filtering (MTMF) is a hybrid method based on the combination of well-known signal processing methodologies and linear mixture theory (Boardman, 1998). This method combines the strength of the Matched Filter method (no requirement to know all the endmembers) with physical constraints imposed by mixing theory (the signature at any given pixel is a linear combination of the individual components contained in that pixel). MTMF uses linear spectral mixing theory to constrain the result to feasible mixtures and to reduce false alarm rates (Boardman, 1998).

MTMF results are presented as two sets of images:

- MF score images with values from 0 to 1.0, estimating the relative degree of match to the reference spectrum (where 1.0 is a perfect match)
- Infeasibility images, where highly infeasible numbers indicate that mixing between the composite background and the target is not feasible. The best match to a target is obtained when the MF score is high (near 1) and the infeasibility score is low (near 0).

Perform Your Own MTMF

Display and compare the EFFORT and MNF Data

1. MTMF requires MNF-transformed data as input. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears.

2. Select cup95mnf.dat, hold down the <Ctrl> key, and select cup95eff.int. Click Open.

3. In the Available Bands List, select the RGB Color radio button. Select MNF bands 1, 2, and 3 under cup95mnf.dat, then click Load RGB.

4. In the Available Bands List, click Display #1 and select New Display.

5. Select bands 183, 193, and 207 under cup95eff.int, then click Load RGB.

6. From one of the Display group menu bars, select Tools → Link → Link Displays. Click OK to link both images.

7. From one of the Display group menu bars, select Tools → Link → Dynamic Overlay Off.

8. From each Display group menu bar, select Tools → Profiles → Z Profile (Spectrum). Move the cursor in the EFFORT image and observe the two spectral profiles. You should see that you cannot effectively use the MNF spectra to identify the materials.

Collect EFFORT and MNF Endmember Spectra

1. From the ENVI main menu bar, select Window → Start New Plot Window. An ENVI Plot Window appears.

2. From the ENVI Plot Window menu bar, select File → Input Data → ASCII. A file selection dialog appears.
3. Select `cup95_em.asc` and click Open. An Input ASCII File dialog appears. Click OK to plot the EFFORT endmember spectra.

4. From the ENVI main menu bar, select **Window → Start New Plot Window**. An ENVI Plot Window appears.

5. From the ENVI Plot Window menu bar, select **File → Input Data → ASCII**. A file selection dialog appears.

6. Select `cup95_mnfem.asc` and click Open. An Input ASCII File dialog appears. Click OK to plot the MNF endmember spectra.

7. Compare the EFFORT and MNF spectra. The MNF spectra will be used with the MNF data to perform MTMF mapping.

**Calculate MTMF Images**

1. From the ENVI main menu bar, select **Spectral → Mapping Methods → Mixture Tuned Matched Filtering**. A file selection dialog appears.

2. Select `cup95mnf.dat` and click OK. An Endmember Collection dialog appears.

3. From the Endmember Collection dialog menu bar, select **Import → From ASCII File**. A file selection dialog appears.

4. Select `cup95_mnfem.asc` (MNF-transformed endmember spectra) and click Open. A Input ASCII File dialog appears. Click OK to load the endmembers.

5. Click Apply in the Endmember Collection dialog. A MTMF Parameters dialog appears.

6. Enter output filenames for the MTMF statistics and for the MTMF image, then click OK. For ease of comparison, these results are also pre-calculated on the Tutorial Data CD #2 in the file `cup95_mtmf.img`.

**Display MTMF Results**

1. In the Available Bands List, load MF score bands as gray scale images.

2. Stretch the images using interactive stretching from 0.0 to 0.25 abundances, and view the pixel distributions for the various endmembers. Try other stretches to minimize false alarms (scattered pixels).

3. In the Available Bands List, select the **RGB Color** radio button. Select **Kaolinite**, **Alunite**, and **Buddingtonite** MF Score bands, and click **Load RGB** to display a color composite of MF scores. Using only MF, kaolinite appears red, alunite green, and buddingtonite blue. This image looks nice, but it has many obvious false positives (every pixel has a color).
Display Scatter Plots of MF Score versus Infeasibility

1. In the Available Bands List, select the Gray Scale radio button, select Band 193 under cup95eff.int, and click Load Band.

2. From any Display group menu bar, select Tools → 2D Scatter Plots. A Scatter Plot Band Choice dialog appears.

3. Under Choose Band X, select the Buddingtonite MF Score band. Under Choose Band Y, select the Buddingtonite Infeasibility band. Click OK. A Scatter Plot window appears.

4. Circle all of the data points with high MF scores and low infeasibilities. Refer to the following figure. The corresponding pixels are highlighted in the Band 193 gray scale image.

5. Notice the highly selective nature and few false positives resulting from MTMF.

6. From the Scatter Plot menu bar, select File → New Scatter Plot. Plot the MF Score and Infeasibility for other endmembers, such as kaolinite and alunite.

7. From each Scatter Plot menu bar, select Options → Export Class to create ROIs showing the individual minerals.

8. Compare your MTMF results to the MF color composite, to the MNF data, to the EFFORT data, and to the unmixing results.

9. Link the display group containing MTMF results with the display group containing EFFORT data. Browse spectra and compare them to the endmember spectra, MTMF images, ROIs, and scatter plots. Extract spectra from the EFFORT data and verify the sensitivity of the MTMF mapping.

10. When you are finished, select File → Exit from the ENVI main menu bar.
References


